<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"32571039","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":11,"applicationTime":196,"agent":""}</script>
<script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<script>
  var googleAnalyticsId = "UA-81884779-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>Rivals.com  -  Takeaways from the Rivals adizero Combine in Houston </title>
<meta content='Rivals.com  -  Takeaways from the Rivals adizero Combine in Houston ' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-1799fc286a65bd6e618a173906afb32ac0ee785bffdfb588c355d039d145cad1.css" />

<script src="https://cdn.rivals.com/production/assets/application-a2c345a5a66333346e4724c601a0c6601acd1f184e5f23345783d990aa532643.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="2Q+WDS8+gNjyZDhU1nXUh6aXFRqMEaB+5xXLV+8PN/45gHuK274mQPv4a+EVnKKZi7RdfdcSkYL9ULuCDv/epg==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/y9xxiqvwggqwkkifgei7' property='og:image'>
<meta content="Several standout players earned their way into Sunday's Rivals 3 Stripe Camp. " property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-17 17:50:17 -0500' property='article:published_time'>
<meta content='2018-03-17 17:50:36 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Felix Etugbo' property='article:tag'>
<meta content='Myles Heard' property='article:tag'>
<meta content='Thomathan Good' property='article:tag'>
<meta content='Layden Robinson' property='article:tag'>
<meta content='Caleb Weaver' property='article:tag'>
<meta content='Dajon Richard' property='article:tag'>
<meta content='George Benyeogor' property='article:tag'>
<meta content='Kyle Maxwell' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='rivals contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .rivals #programming > h1 {
      background-color: #0A4EA3 !important; } }
  .rivals > header .notification-link .count-container {
    background-color: #0A4EA3 !important; }
  .rivals > header .wrapper-container {
    background-color: #0A4EA3 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .rivals > header .wrapper-container {
        border-bottom: 5px solid #464646 !important; } }
  .rivals > header .invalid-email-banner {
    background-color: #0A4EA3;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .rivals > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .rivals > header .invalid-email-banner a:hover {
      color: #464646; }
  @media screen and (max-width: 767px) {
    .rivals > header .mobile-header {
      background-color: #464646 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .rivals > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .rivals > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .rivals > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .rivals > header .nav-row > ul,
    .rivals > header .third-nav {
      background-color: white !important; }
    .rivals > header .dropdown-toggle > i.fa {
      color: #0A4EA3 !important; } }
  .rivals > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #0A4EA3; }
  
  .site-primary-font-color {
    color: #0A4EA3; }
  
  .site-primary-background-color {
    background-color: #0A4EA3; }
  
  .site-secondary-font-color {
    color: #464646; }
  
  .site-secondary-background-color {
    background-color: #464646; }
  
  :root {
    --outbrain-primary-color: #0A4EA3;
    --outbrain-secondary-color: #464646; }
</style>

<header><nav ng-class='currentUser ? "signed-in" : "signed-out"' ng-controller='NavController' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='toggleContentNav($event)'></a>
      <a alt="Rivals" class="school-header" href="//Rivals.rivals.com"><img src="https://res-1.cloudinary.com/rivals/image/upload/g9w1wh9jn8o0vwpx19or" alt="G9w1wh9jn8o0vwpx19or" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{subscribePath}}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current-user='currentUser'></rv-user-dropdown>
        <rv-forums-info current-user='currentUser' ng-if='currentUser && (isDesktop || isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!isTablet'>
      <ul>
        <li class="home top-nav"><a href="//Rivals.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;rivals&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="currentUser" ng-if="!isTablet &amp;&amp; !isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='isTablet'>
      <ul>
        <li class="home top-nav"><a href="//Rivals.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;rivals&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="currentUser" ng-if="!isTablet &amp;&amp; !isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='showEmailUpdateBanner'>
      <a ng-href='{{userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719147,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Takeaways from the Rivals adizero Combine in Houston "
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='rivals' name='twitter:site'>
<meta content='Takeaways from the Rivals adizero Combine in Houston ' name='twitter:title'>
<meta content="Several standout players earned their way into Sunday's Rivals 3 Stripe Camp. " name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/y9xxiqvwggqwkkifgei7' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1905280,"title":"LIVE from Houston: Area&#x0027;s best turns out for Rivals 3 Stripe Camp","slug":"live-from-houston-area-s-best-turns-out-for-rivals-3-stripe-camp","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-18T09:52:45.242-05:00","summary":"The Rivals 3 Stripe Camp presented by adidas of 2018 is underway in Houston and we have all of the news covered.","deleted":false,"author_name":"Staff","author_title":"Rivals.com","permalink":"https://n.rivals.com/news/live-from-houston-area-s-best-turns-out-for-rivals-3-stripe-camp","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1905299,"title":"Gorney&#x0027;s Takeaways: adidas West Coast Invitational","slug":"gorney-s-takeaways-adidas-west-coast-invitational","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-18T10:24:55.944-05:00","summary":"Three-star Brayden Liebrook impressed Saturday at the adidas West Coast Invitational.","deleted":false,"author_name":"Adam Gorney","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/gorney-s-takeaways-adidas-west-coast-invitational","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904871,"title":"Rivals Camp Series in Houston: What to watch for this weekend","slug":"rivals-camp-series-in-houston-predictions-for-the-weekend","kind":"free","site_id":173,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-17T09:29:32.293-05:00","summary":"The Texas stop won&#x0027;t be lacking in talent - or players hoping to improve their rankings. ","deleted":false,"author_name":"Nick Krueger","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rivals-camp-series-in-houston-predictions-for-the-weekend","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904848,"title":"Eighth-grade Tennessee QB nabs offer from Harbaugh, Michigan","slug":"eighth-grade-tennessee-qb-nabs-first-offer-from-jim-harbaugh-michigan","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T14:41:45.592-05:00","summary":"The son of UT-Martin head coach says, &#x0027;It gives me a little spark to know I can conquer my dreams.&#x0027;","deleted":false,"author_name":"Woody Wommack","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/eighth-grade-tennessee-qb-nabs-first-offer-from-jim-harbaugh-michigan","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904894,"title":"Top-ranked Quavaris Crouch talks faith, football, future","slug":"top-ranked-quavaris-crouch-talks-faith-football-future","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-16T17:08:47.975-05:00","summary":"The nation&#x0027;s top-ranked prospect, Quavaris Crouch, talks with VolQuest.com.","deleted":false,"author_name":"Austin Price","author_title":"VolQuest.com","permalink":"https://tennessee.rivals.com/news/top-ranked-crouch-talks-faith-family-and-football","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904540,"title":"Take Two: Will Texas turn things around in 2018?","slug":"take-two-will-texas-turn-things-around-in-2018-","kind":"free","site_id":173,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T06:22:40.196-05:00","summary":"Is this the year that Texas, finally, turns things around?","deleted":false,"author_name":"Adam Gorney","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/take-two-will-texas-turn-things-around-in-2018-","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904279,"title":"Rivals 3 Stripe Camp standouts name favorite assistant coaches","slug":"rivals-3-stripe-camp-standouts-name-favorite-assistant-coaches","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T11:12:38.906-05:00","summary":"Top prospects on the West Coast told us who their favorite assistant coaches are and why.","deleted":false,"author_name":"Adam Gorney, Nick Krueger and Woody Wommack","author_title":"Rivals.com","permalink":"https://n.rivals.com/news/rivals-3-stripe-camp-standouts-name-favorite-assistant-coaches","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904476,"title":"West Coast prospects give reasons for Pac-12&#x0027;s title drought","slug":"west-coast-prospects-give-reasons-for-pac-12-s-title-drought","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T06:11:26.373-05:00","summary":"Prospects at the California Rivals 3 Stripe Camps weigh in on why the Pac-12 hasn&#x0027;t had a national champ in 14 years.","deleted":false,"author_name":"Woody Wommack","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/west-coast-prospects-give-reasons-for-pac-12-s-title-drought","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904638,"title":"Big 12 Spotlight: Five spring position battles to track","slug":"big-12-spotlight-five-spring-position-battles-to-track","kind":"free","site_id":173,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-16T07:42:54.736-05:00","summary":"McLane Carter will be part of one of the most watched position battles in the Big 12 this spring.","deleted":false,"author_name":"Mike Farrell","author_title":"Recruiting Director","permalink":"https://n.rivals.com/news/big-12-spotlight-five-spring-position-battles-to-track","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1905298,"title":"RCS Houston: Five-star Kenyon Green hopes to shorten list soon","slug":"rcs-houston-five-star-kenyon-green-hopes-to-shorten-list-soon","kind":"premium","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Video","live_at":"2018-03-18T09:58:35.069-05:00","summary":"Five-star OL Kenyon Green hopes to narrow a list of ten favorites soon. Find out what schools are in good position.","deleted":false,"author_name":"Nick Krueger","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rcs-houston-five-star-kenyon-green-hopes-to-shorten-list-soon","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1905296,"title":"RCS Houston: Derek Stingley Jr. focused on LSU, five contenders","slug":"rcs-houston-derek-stingley-jr-focused-on-lsu-five-contenders","kind":"premium","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Video","live_at":"2018-03-18T09:44:09.764-05:00","summary":"Rivals.com analyst Chad Simmons and five-star DB Derek Stingley Jr. discuss the LSU Tigers and more.","deleted":false,"author_name":"Chad Simmons","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rcs-houston-derek-stingley-jr-focused-on-lsu-five-contenders","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1905284,"title":"RCS Houston: Rivals100 DB Erick Young working toward decision","slug":"rcs-houston-rivals100-db-erick-young-working-toward-decision","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Video","live_at":"2018-03-18T09:21:08.412-05:00","summary":"Rivals100 DB Erick Young hopes to make a commitment prior to his senior year.  ","deleted":false,"author_name":"Nick Krueger","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rcs-houston-rivals100-db-erick-young-working-toward-decision","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1905283,"title":"RCS Houston: Zachary Evans talks in-state powers and more","slug":"rcs-houston-zachary-evans-talks-in-state-powers-and-more","kind":"premium","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Video","live_at":"2018-03-18T08:59:10.333-05:00","summary":"HOUSTON - Top 2020 RB Zachary Evans talks Texas, Texas A\u0026M and more at the Rivals Camp Series.","deleted":false,"author_name":"Nick Krueger","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rcs-houston-zachary-evans-talks-in-state-powers-and-more","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1905101,"title":"Five-star DL Zacch Pickens updates his recruitment","slug":"five-star-dl-zacch-pickens-updates-his-recruitment","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-17T15:34:17.413-05:00","summary":"Five-star DL Zacch Pickens updates his recruitment","deleted":false,"author_name":"Adam  Friedman","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/five-star-dl-zacch-pickens-updates-his-recruitment","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904989,"title":"Rivals250 QB Sam Howell previews his March visits \u0026 more","slug":"rivals250-qb-sam-howell-previews-his-march-visits-more","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-17T06:48:19.225-05:00","summary":"March is a big month for Rivals250 quarterback Sam Howell because he has a lot of visits on deck. More details here.","deleted":false,"author_name":"Adam  Friedman","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rivals250-qb-sam-howell-previews-his-march-visits-more","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904874,"title":"Rivals100 OL John Olmstead breaks down his top 10 \u0026 upcoming visits","slug":"rivals100-ol-john-olmstead-breaks-down-his-top-10-upcoming-visits","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-16T16:12:45.623-05:00","summary":"Rivals100 offensive lineman John Olmstead breaks down his top ten and upcoming visits.","deleted":false,"author_name":"Adam  Friedman","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/rivals100-ol-john-olmstead-breaks-down-his-top-10-upcoming-visits","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904484,"title":"Four-star QB Michael Johnson Jr. planning big visits","slug":"four-star-qb-michael-johnson-jr-planning-big-visits","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T14:07:55.946-05:00","summary":"Four-star quarterback Michael Johnson Jr. is planning an important round of visits.","deleted":false,"author_name":"Adam Gorney","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/four-star-qb-michael-johnson-jr-planning-big-visits","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904322,"title":"Rivals 3 Stripe Camp standouts weigh in on new Pac-12 coaches","slug":"rivals-3-stripe-camp-standouts-weigh-in-on-new-pac-12-coaches","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T11:49:33.323-05:00","summary":"West Coast prospects weigh in on the Pac-12&#x0027;s five new head coaches.","deleted":false,"author_name":"Nick Krueger and Woody Wommack","author_title":"Rivals.com","permalink":"https://n.rivals.com/news/rivals-3-stripe-camp-standouts-weigh-in-on-new-pac-12-coaches","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904413,"title":"Three teams stand out most to QB Cade McNamara","slug":"three-teams-stand-out-most-to-qb-cade-mcnamara","kind":"free","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T11:33:53.591-05:00","summary":"Four-star quarterback Cade McNamara is most focused on three schools.","deleted":false,"author_name":"Adam Gorney","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/three-teams-stand-out-most-to-qb-cade-mcnamara","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904411,"title":"Ohio DE Spencer Bono has four schools standing out","slug":"ohio-de-spencer-bono-has-four-schools-standing-out","kind":"premium","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T11:30:25.428-05:00","summary":"Four schools stand out for Cincinnati DE Spencer Bono, and he will visit one of those programs this weekend.","deleted":false,"author_name":"Josh Helmholdt","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/ohio-de-spencer-bono-has-four-schools-standing-out","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904211,"title":"Pac-12 Spotlight: Five spring position battles to track","slug":"pac-12-spotlight-five-spring-position-battles-to-track","kind":"free","site_id":173,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-15T10:24:13.118-05:00","summary":"The glamour quarterback spot at both Los Angeles schools is up for grabs.","deleted":false,"author_name":"Mike Farrell","author_title":"Recruiting Director","permalink":"https://n.rivals.com/news/pac-12-spotlight-five-spring-position-battles-to-track","site_name":"Rivals.com","type":"Content","associated_links":[]},{"id":1904388,"title":"Toledo’s Jase Bowen replots his course","slug":"toledo-s-jase-bowen-replots-his-course","kind":"premium","site_id":173,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-15T10:02:30.885-05:00","summary":"Toledo&#x0027;s Jase Bowen de-committed from Notre Dame baseball earlier this week and football is now his priority.","deleted":false,"author_name":"Josh Helmholdt","author_title":"Recruiting Analyst","permalink":"https://n.rivals.com/news/toledo-s-jase-bowen-replots-his-course","site_name":"Rivals.com","type":"Content","associated_links":[]}],nil,173,nil,nil,true); subdomain = &#x0027;rivals&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='facebook-ad-container horizontal'>
<div class='mobile-banner' style='display:none; position: relative;'>
<iframe style='display:none;'></iframe>
<script>
  var data = {
    placementid: '223720088042238_252396341841279',
    format: '320x50',
    testmode: false,
    onAdLoaded: function(element) {
      element.style.display = 'block';
    },
    onAdError: function(errorCode, errorMessage) {
    }
  };
  (function(w,l,d,t){var a=t();var b=d.currentScript||(function(){var c=d.getElementsByTagName('script');return c[c.length-1];})();var e=b.parentElement;e.dataset.placementid=data.placementid;var f=function(v){try{return v.document.referrer;}catch(e){}return'';};var g=function(h){var i=h.indexOf('/',h.indexOf('://')+3);if(i===-1){return h;}return h.substring(0,i);};var j=[l.href];var k=false;var m=false;if(w!==w.parent){var n;var o=w;while(o!==n){var h;try{m=m||(o.$sf&&o.$sf.ext);h=o.location.href;}catch(e){k=true;}j.push(h||f(n));n=o;o=o.parent;}}var p=l.ancestorOrigins;if(p){if(p.length>0){data.domain=p[p.length-1];}else{data.domain=g(j[j.length-1]);}}data.url=j[j.length-1];data.channel=g(j[0]);data.width=screen.width;data.height=screen.height;data.pixelratio=w.devicePixelRatio;data.placementindex=w.ADNW&&w.ADNW.Ads?w.ADNW.Ads.length:0;data.crossdomain=k;data.safeframe=!!m;var q={};q.iframe=e.firstElementChild;var r='https://www.facebook.com/audiencenetwork/web/?sdk=5.3';for(var s in data){q[s]=data[s];if(typeof(data[s])!=='function'){r+='&'+s+'='+encodeURIComponent(data[s]);}}q.iframe.src=r;q.tagJsInitTime=a;q.rootElement=e;q.events=[];w.addEventListener('message',function(u){if(u.source!==q.iframe.contentWindow){return;}u.data.receivedTimestamp=t();if(this.sdkEventHandler){this.sdkEventHandler(u.data);}else{this.events.push(u.data);}}.bind(q),false);q.tagJsIframeAppendedTime=t();w.ADNW=w.ADNW||{};w.ADNW.Ads=w.ADNW.Ads||[];w.ADNW.Ads.push(q);w.ADNW.init&&w.ADNW.init(q);})(window,location,document,Date.now||function(){return+new Date;});
</script>
<script async src='https://connect.facebook.net/en_US/fbadnw.js' type='text/javascript'></script>
</div>

</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #0A4EA3'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if>
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad' ng-if='true'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>
<rv-custom-ad ad='{"id":86,"image_id":548091,"url":"http://www.rivalsfanstore.com/?utm_source=rivalsscom\u0026utm_medium=bm_referral\u0026utm_term=kw--RivalsPromo|cpn--no_coupon|offer--no_offer\u0026utm_content=L--College|t--all_NCAA_schools|p--all_players|pc--all_product_categories|ag--NoGender\u0026utm_campaign=dest--www_rivals_com|creatv--RivalsPromo|date--52115|geo--NoGeo","position":2,"site_id":173,"created_at":"2016-02-05T09:22:15.880-06:00","updated_at":"2016-09-13T11:39:22.775-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/opntmiruasanfl2a7ssi"}' class='ad-two'></rv-custom-ad>
<div class='side-rail-meta lrec-ad' ng-if='true'></div>
<div class='side-rail-meta lrec-ad' ng-if='true'></div>

<rv-homepage-forums ad-referer='https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston' background-color='#0A4EA3' base-api-url='https://forums.rivals.com/' homepage='false' message-board-url='rivals.forums.rivals.com' pub-ad='{"id":86,"image_id":548091,"url":"http://www.rivalsfanstore.com/?utm_source=rivalsscom\u0026utm_medium=bm_referral\u0026utm_term=kw--RivalsPromo|cpn--no_coupon|offer--no_offer\u0026utm_content=L--College|t--all_NCAA_schools|p--all_players|pc--all_product_categories|ag--NoGender\u0026utm_campaign=dest--www_rivals_com|creatv--RivalsPromo|date--52115|geo--NoGeo","position":2,"site_id":173,"created_at":"2016-02-05T09:22:15.880-06:00","updated_at":"2016-09-13T11:39:22.775-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/opntmiruasanfl2a7ssi"}' size='size' space-id='2022719147' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston/printable' site-name='Rivals.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-17 17:50:17 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1905142/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Takeaways from the Rivals adizero Combine in Houston </h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='title-sm' id='onetime-author'>Nick Krueger and Woody Wommack </div>
<div class='type-sm'>Rivals.com</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>HOUSTON - The sixth of 14 nationwide <i><b>Rivals adizero Combine</b> </i>events took place Saturday at CE King High School, with about 1,500 athletes turning out to compete.</p><p>After all of the performances, several players earned a spot in Sunday’s <b>Rivals 3 Stripe Camp Series presented by adidas</b> event. Here’s the rundown of the players who earned their way into the camp.</p><p><b>RELATED:</b> <a href="https://n.rivals.com/news/rivals-camp-series-presented-by-adidas-2018-faqs">Full Rivals Camps Series schedule &amp; FAQs</a></p><p><b>CLASS OF 2019 RANKINGS:</b> <a href="https://n.rivals.com/prospect_rankings/rivals250/2019">Rivals250</a> | <a href="https://n.rivals.com/news/rivals-com-s-class-of-2019-state-rankings">State</a> | <a href="https://n.rivals.com/news/rivals-2019-position-rankings">Position</a> | <a href="https://n.rivals.com/team_rankings/2019/all-teams/football">Team</a></p>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='184603'></rv-prospect-profile>
</div>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/y9xxiqvwggqwkkifgei7)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/y9xxiqvwggqwkkifgei7" alt="Y9xxiqvwggqwkkifgei7" />
</div>
<figcaption class='image-caption'>Kyle Maxwell </figcaption>
<div class='image-credit'>Nick Lucero/Rivals.com</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>The first combine invite of the day was Louisiana product Kyle Maxwell. The 2019 athlete holds offers from <a href="https://memphis.rivals.com">Memphis</a> and <a href="https://tulane.rivals.com">Tulane</a>, but <a href="https://tennessee.rivals.com">Tennessee</a> could be the next team interested after Tigers wide receivers coach <b>David Johnson</b> made the move to Knoxville to join the Volunteers staff. Maxwell said that he hopes that relationship will lead to his first SEC offer.</p><p>“Coach [Johnson] is the one that offered me and he’s out at Tennessee now,” Maxwell said. “He’s from Louisiana, he’s almost like a father figure. He knows what we go through in Louisiana, and I like how he talks to me and treats me. He treats me with respect.”</p><p>Otherwise, he said that he has been in contact with <a href="https://kentucky.rivals.com">Kentucky</a>, <b>Louisiana-Lafayette</b> and <b>Louisiana-Monroe</b>, but has a good relationship with the Tulane staff and he has an open invitation to return to campus.</p><p>“Me and Coach <b>(Wesley) Fritz</b> are cool, he invited me out for visits and junior days,” he said. “I really don’t know when I can get out there again, but everything is good with them.”</p>
</div>
<h3 class='article-heading'>*****</h3>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/setln3qjrjakaorj8u67)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/setln3qjrjakaorj8u67" alt="Setln3qjrjakaorj8u67" />
</div>
<figcaption class='image-caption'>Jett Bush </figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Houston-Strake Jesuit linebacker <b>Jett Bush</b> has a chance to continue making a strong impression this weekend after getting off to a strong start on Saturday. He earned an invitation after posting strong times and measurements at each event. He started his football career as a quarterback but switched to linebacker last season and totaled over 125 tackles and had six sacks. So far this spring, he’s taken junior day visits to <a href="https://houston.rivals.com">Houston</a> and <b>North Texas</b>.</p><p>“I was really impressed with both schools’ junior days,” he said. “Especially Houston; they have everything I want in the facilities and they really have something special going on there. North Texas also has something special, and I really like the coaches.”</p>
</div>
<h3 class='article-heading'>*****</h3>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ftl9lhqm7dqwrwh5chpv)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ftl9lhqm7dqwrwh5chpv" alt="Ftl9lhqm7dqwrwh5chpv" />
</div>
<figcaption class='image-caption'>Jermarques Bailey </figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>One of Houston’s most popular names early in the camp season has been <b>Jermarques Bailey</b>. After showing up on Saturday and looking more the part of a dominating lineman than most others at his position, he performed well in all the physical tests and punched his ticket for Sunday. In addition to <b><a href="https://tamu.rivals.com">Texas A&amp;M</a></b> and <b>Penn </b>showing interest in him this spring, he’s taken a recent visit to <a href="https://baylor.rivals.com">Baylor</a> and is anticipating making more visits in the coming weeks.</p><p>“My old head coach, Coach <b>(Joey) McGuire</b>, he invited me to the first spring practice and it was good,” he said. “There was a lot of energy, a lot of work, and just looking around it was really great. I had a chance to talk to the head coach and the O-line coach, they showed me the new facilities and it was a great experience.”</p>
</div>
<h3 class='article-heading'>*****</h3>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='211452'></rv-prospect-profile>
</div>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/z8qphzdrxi0bfb4xdwhk)'></div>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/z8qphzdrxi0bfb4xdwhk" alt="Z8qphzdrxi0bfb4xdwhk" />
</div>
<figcaption class='image-caption'>George Benyeogor</figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Katy-Tompkins 2020 running back George Benyeogor will make his return on Sunday after putting up scat-back numbers in a power-back’s frame. He missed most of his sophomore season with a separated shoulder in 2017, but is part of an exciting young core of players that is expected to lead the program to more positive results this fall. He recently took a visit to <b><a href="https://arkansas.rivals.com">Arkansas</a>, </b>and said that he’s ready to see some more nearby options before the end of spring.</p><p>“It was fun. Their campus was nice, they have some good running backs and a good line,” he said. “I talked to one of the defensive coaches because he recruits our area and he said that he’ll be keeping track of me. Coming up, I’d like to focus on some of the in-state schools like <a href="https://texas.rivals.com">Texas</a>, <a href="https://tamu.rivals.com">(Texas) A&amp;M</a>, <b>UNT</b> and <b>Texas State,</b> because they’re so close and I can just stop in.”</p>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='181662'></rv-prospect-profile>
</div>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/jkcomgzgm1tkxg9uwobg)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/jkcomgzgm1tkxg9uwobg" alt="Jkcomgzgm1tkxg9uwobg" />
</div>
<figcaption class='image-caption'>Dajohn Richard </figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>The state of Louisiana was well-represented at the event, and Class of 2019 athlete Dajohn Richard earned his invite after clocking a 4.3 second 40-yard dash. The versatile athlete has offers from FCS programs <b>Southeastern</b> and <b>Howard</b> and was planning to stop by <a href="https://houston.rivals.com">Houston</a> while in the area. The Cougars are among the programs showing interest, along with <a href="https://tamu.rivals.com">Texas A&amp;M</a>. Richard has plans to attend several school camps during the spring and summer. </p>
</div>
<h3 class='article-heading'>BEST OF THE REST </h3>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/diotdrdjig6iebunrpza)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/diotdrdjig6iebunrpza" alt="Diotdrdjig6iebunrpza" />
</div>
<figcaption class='image-caption'>Layden Robinson </figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Other invites included: 2021 Houston Jersey Village cornerback <b><a href="https://n.rivals.com/content/prospects/2021/caleb-weaver-188790">Caleb Weaver</a></b>, 2020 Missouri City (Texas) Thurgood Marshall WR <b>Alontai Brewer</b>, 2019 Manvel (Texas) guard <b><a href="https://n.rivals.com/content/prospects/2019/layden-robinson-216925">Layden Robinson</a></b>, 2019 Houston defensive tackle <b><a href="https://n.rivals.com/content/prospects/2019/thomathan-good-205313">Thomathon Good</a>, </b>Houston linebacker <b>Jamie Broussard, </b>Houston wide receiver <b>Trenton Waggoner</b>, Houston quarterback <b>Zack Daniel</b>, Houston safety <b><a href="https://n.rivals.com/content/prospects/2019/myles-heard-190321">Myles Heard</a></b>, Houston linebacker <b>Ezrah Thibodeaux </b>and Houston LB/DE <b><a href="https://n.rivals.com/content/prospects/2019/felix-etugbo-185149">Felix Etugbo</a>. </b></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston/printable' site-name='Rivals.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='{"id":86,"image_id":548091,"url":"http://www.rivalsfanstore.com/?utm_source=rivalsscom\u0026utm_medium=bm_referral\u0026utm_term=kw--RivalsPromo|cpn--no_coupon|offer--no_offer\u0026utm_content=L--College|t--all_NCAA_schools|p--all_players|pc--all_product_categories|ag--NoGender\u0026utm_campaign=dest--www_rivals_com|creatv--RivalsPromo|date--52115|geo--NoGeo","position":2,"site_id":173,"created_at":"2016-02-05T09:22:15.880-06:00","updated_at":"2016-09-13T11:39:22.775-05:00","image_url":"https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_ad/opntmiruasanfl2a7ssi"}' enrichments='[{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":3,"footballYear":2019,"basketballYear":2018}]' hide-yahoo-ad='false' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":173,"legacy_id":1014,"name":"Rivals.com","friendly_name":"Rivals","annual_discount":null,"subdomain":"rivals","primary_color":"0A4EA3","secondary_color":"464646","font_color":"ffffff","short_name":"Rivals","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81884779-1"}' twitter-feed='{"id":172,"site_id":173,"handle":"rivals","list_name":"Rivals-National","created_at":"2016-02-01T12:25:40.011-06:00","updated_at":"2017-09-05T11:55:48.870-05:00","hashtags":[],"usernames":[],"max_number":null}' yahoo-ad-present></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston/printable' site-name='Rivals.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719147', 'https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Takeaways from the Rivals adizero Combine in Houston ";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer') &amp;&amp; true &amp;&amp; (true)">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://n.rivals.com' data-widget-id='AR_4' ng-if='true'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='https://n.rivals.com/news/terms-of-service'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719147",
    c7: "https://n.rivals.com/news/takeaways-from-the-rivals-adizero-combine-in-houston"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fn.rivals.com%2Fnews%2Ftakeaways-from-the-rivals-adizero-combine-in-houston&c5=2022719147&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
