<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"32571039,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":4,"applicationTime":339,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81884779-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>Rivals.com  -  Early Signing Period: Late additions that flew under the radar </title>
<meta content='Rivals.com  -  Early Signing Period: Late additions that flew under the radar ' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-0a2461873193d257ec63b685e3067a346570990262a29b886c02832fb4404399.css" />


<script src="https://cdn.rivals.com/production/assets/lib-2c36456a4b9312c690be6edf2f9c0f68573b9c6dd3578b41040f58f24d0b7c51.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-3d36219f30a13077608f747ea50dc0d000fa08853c79caed70c7f21a4c56f15b.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="fpGKCHpuPsuc3XbJLKALLAFf6yYiRYZ6xnFMyaoUdGChk3TLXVzNjmDGOIRNVJuGbUQjFBc9Y1sV9KDdyXB6dg==" />
<script>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</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_hero_desktop/rylcumk4wmzznr2upfnz' property='og:image'>
<meta content="Tennessee's Friday night addition of Quavaris Crouch flew under the radar. " property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-12-23 10:23:23 -0600' property='article:published_time'>
<meta content='2018-12-23 10:23:24 -0600' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Quavaris Crouch' property='article:tag'>
<meta content='Will Putnam' property='article:tag'>
<meta content='Isaiah	 Hookfin' property='article:tag'>
<meta content='Eric Gray' property='article:tag'>
<meta content='Xavier Legette' property='article:tag'>
<meta content='Adam Elgammal' property='article:tag'>
<meta content='Shahman Moore' property='article:tag'>
<meta content='Isaiah Howard' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='rivals contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .rivals #programming > h1 {
      background-color: #0A4EA3 !important; } }
  .rivals > header .notification-link .count-container {
    background-color: #0A4EA3 !important; }
  .rivals > header .wrapper-container {
    background-color: #0A4EA3 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .rivals > header .wrapper-container {
        border-bottom: 5px solid #464646 !important; } }
  .rivals > header .invalid-email-banner {
    background-color: #0A4EA3;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .rivals > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .rivals > header .invalid-email-banner a:hover {
      color: #464646; }
  @media screen and (max-width: 767px) {
    .rivals > header .mobile-header {
      background-color: #464646 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .rivals > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .rivals > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .rivals > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .rivals > header .nav-row > ul,
    .rivals > header .third-nav {
      background-color: white !important; }
    .rivals > header .dropdown-toggle > i.fa {
      color: #0A4EA3 !important; } }
  .rivals > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #0A4EA3; }
  
  .site-primary-font-color {
    color: #0A4EA3; }
  
  .site-primary-background-color {
    background-color: #0A4EA3; }
  
  .site-secondary-font-color {
    color: #464646; }
  
  .site-secondary-background-color {
    background-color: #464646; }
  
  :root {
    --outbrain-primary-color: #0A4EA3;
    --outbrain-secondary-color: #464646; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Rivals" class="school-header" href="https://rivals.rivals.com/"><img src="https://res-1.cloudinary.com/rivals/image/upload/g9w1wh9jn8o0vwpx19or" alt="G9w1wh9jn8o0vwpx19or" />
      </a>
      <div class='nav-center-controls'>
        <a class='user-gift-header' ng-href='{{ctrl.giftPurchasePath}}' ng-if='!ctrl.unsubscribed && !ctrl.isMobile'>
          <div class='gift-icon'></div>
          <span>Give a Rivals gift subscription</span>
        </a>
      </div>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <div class='line' ng-if='ctrl.showSubscribe()'></div>
        <a class='gift-header' ng-href='{{ctrl.giftPurchasePath}}' ng-if='ctrl.showSubscribe()'>
          <div class='gift-icon'></div>
          <span>GIFT SUBSCRIPTION</span>
        </a>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://rivals.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;rivals&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://rivals.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;rivals&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719147,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Early Signing Period: Late additions that flew under the radar "
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='rivals' name='twitter:site'>
<meta content='Early Signing Period: Late additions that flew under the radar ' name='twitter:title'>
<meta content="Tennessee's Friday night addition of Quavaris Crouch flew under the radar. " name='twitter:description'>
<meta content='https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/rylcumk4wmzznr2upfnz' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":173,"legacy_id":1014,"name":"Rivals.com","friendly_name":"Rivals","annual_discount":null,"subdomain":"rivals","primary_color":"0A4EA3","secondary_color":"464646","font_color":"ffffff","short_name":"Rivals","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81884779-1"}, true, 172, nil, {"id":161,"primary_color":"0A4EA3","secondary_color":"464646","font_color":"ffffff","commitment_module_football":false,"rivals_module_football":true,"header_name":"","header_logo_cloudinary":"g9w1wh9jn8o0vwpx19or","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81884779-1","logo_background_shading":"white","football_content":false,"basketball_content":false,"baseball_content":false,"other_content":false,"site_id":173,"created_at":"2016-11-23T13:38:45.399-06:00","updated_at":"2018-12-18T19:57:57.021-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"FancastLeaderboard","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://rivals.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"58e686759efa8936610b8215","aol_company_id":"58e68374c7480e728bcc385f","ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":true},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000, true)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #0A4EA3'>
Ticker
</div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period' background-color='#0A4EA3' base-api-url='https://forums.rivals.com/' homepage='false' message-board-url='https://rivals.forums.rivals.com' pub-ad='null' size='size' space-id='2022719147' subscribed-user='subscribedUser'></rv-homepage-forums>

<div class='ads'>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://n.rivals.com' data-widget-id='AR_4' in-side-rail='true' rv-add-class-at-top='fixed-top' sibling-container='article-display-wrapper' top-padding='0'>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>
</div>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period/printable' site-name='Rivals.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-12-23 10:23:23 -0600') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1997416/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Early Signing Period: Late additions that flew under the radar </h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='title-sm' id='onetime-author'>Woody Wommack and Mike Farrell</div>
<div class='type-sm'>Rivals.com</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><b>CLASS OF 2019 RANKINGS:</b> <a href="https://n.rivals.com/prospect_rankings/rivals250/2019">Rivals250</a> | <a href="https://n.rivals.com/news/rivals-com-s-class-of-2019-state-rankings">State</a> | <a href="https://n.rivals.com/news/rivals-2019-position-rankings">Position</a> | <a href="https://n.rivals.com/team_rankings/2019/all-teams/football">Team</a></p><p><b>CLASS OF 2020 RANKINGS: <a href="https://n.rivals.com/prospect_rankings/rivals250/2020">Rivals250</a> | <a href="https://n.rivals.com/news/class-of-2020-state-rankings">State</a> | <a href="https://n.rivals.com/news/class-of-2020-position-rankings">Position</a><br></b></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/rylcumk4wmzznr2upfnz)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/rylcumk4wmzznr2upfnz" alt="Rylcumk4wmzznr2upfnz" />
</div>
<figcaption class='image-caption'>Quavaris Crouch</figcaption>
<div class='image-credit'>Nick Lucero/Rivals.com</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p> <b>MORE: <a href="https://n.rivals.com/news/sting-factor-the-10-biggest-stings-of-the-early-signing-period">The 10 biggest stings of the Early Signing Period</a> | <a href="https://n.rivals.com/news/top-10-uncommitted-prospects-after-the-early-signing-period">Top uncommitted prospects</a></b></p><p>The college football world is still adjusting to the new Early Signing Period, with the first Wednesday essentially becoming the new National Signing Day. More than 80 percent of the country’s four-star prospects signed on that day, leaving most schools with nearly complete classes. But while most of the focus was on which prospects made it official on Wednesday, several more key pieces sent in their letters on Thursday and Friday, prior to the close of the period. Today, we take a look at the late additions that might have flown under the radar and rank them in terms of their impact. </p>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='12988'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>The one-time No. 1 overall player in the 2019 class, Crouch waited until the window to sign almost closed before announcing his commitment to <a href="https://tennessee.rivals.com">Tennessee </a>on Friday night. Crouch actually submitted financial aid paperwork to <a href="https://michigan.rivals.com">Michigan</a>, <a href="https://clemson.rivals.com">Clemson</a> and Tennessee, keeping fans and coaches guessing as to where he was going and when he would announce. But Tennessee’s longtime courtship of Crouch paid off in a major way and now he’s officially in the fold. A two-way player who could fit at running back or outside linebacker with the Vols, Crouch should have the opportunity to make an instant impact.</p><p> <b>Farrell’s take: </b>Clemson was supposed to be the favorite for Crouch, so for Tennessee to pull this one out is impressive. Crouch is a terrific athlete and could impact in many ways, but I think his future is on the defensive side of the ball as a big, physical linebacker that could transform the Vols' defense. If he stays healthy, he’ll be a leader on defense and a guy who sets the tone with his physical nature. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://tennessee.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/jlzinzaoxhaohpqfmfzm)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/jlzinzaoxhaohpqfmfzm" alt="Jlzinzaoxhaohpqfmfzm" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='28780'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Putnam became a very coveted name in recruiting circles during the fall, with several of college football’s heavy hitters vying to land him. His recruitment boiled down to <a href="https://auburn.rivals.com">Auburn</a>, <a href="https://floridastate.rivals.com">Florida State</a> and Clemson, with each team looking like it led at various times during his recruitment. After Clemson was edged out for a few late targets on Wednesday, beating out the Seminoles for Putnam was a major victory.</p><p><b>Farrell’s take: </b>I like Putnam a lot and think he can play early for Clemson. This is another very good pickup for <b>Dabo Swinney </b>and company from Florida and they continue to beat impressive programs head-to-head for top prospects. I project Putnam as an inside lineman on offense who can pull and get out in space and will be very good at the second level. He needs to fill out and add strength but once he does watch out. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://clemson.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gevcuarvpvkebl4lfxxc)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gevcuarvpvkebl4lfxxc" alt="Gevcuarvpvkebl4lfxxc" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='219361'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Hookfin was set to announce on Wednesday but then his expected time came and went, leaving fans and coaches to guess about what happened. The speculation didn’t last for long, though, as Hookfin gave Longhorns fans good news with his official commitment and signature on Friday morning. The athletic offensive lineman became a late priority for <a href="https://texas.rivals.com">Texas</a>, and the late push helped the Horns land him over <a href="https://baylor.rivals.com">Baylor </a>and <a href="https://minnesota.rivals.com">Minnesota</a>.</p><p><b>Farrell’s take: </b>Hookfin, like Putnam, needs to fill out and add strength but he has a very high ceiling and fills a big positional need for the Longhorns. He’s part of a small but important offensive line class for Texas and he could be the best of the group. He’s a bit raw right now but I could see him starting as an elite left tackle in a couple of years. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://texas.n.rivals.com/' target='_blank'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/rnpr4xnpbwohzj6cruka)'></div>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/rnpr4xnpbwohzj6cruka" alt="Rnpr4xnpbwohzj6cruka" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='22913'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Some speculated that Gray set his announcement for Thursday just to see how things would shake out with the schools on his list, but as it turned out, everything went as planned and he committed to Tennessee, as most expected. The Vols were the favorite to land Gray, even when he was committed to Michigan, and his commitment started a great couple of days of buzz for the school.</p><p><b>Farrell’s take: </b>Gray might be overshadowed by Crouch a bit in the Tennessee, class but he’s equally important. He’s the kind of running back who can make a big play from anywhere and can be effective in the passing game as well. A slasher, he can make people miss and has very good vision and I think he can be an early impact guy for the Vols. </p>
</div>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='234207'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>An under-the-radar prospect that emerged with several SEC offers after posting some excellent senior film, Legette was a late grab by the Gamecocks after a spot opened up in their class. Most had expected Legette to wait to sign until February and he might have been a popular name among programs looking to add late talent had he waited. <a href="https://southcarolina.rivals.com">South Carolina</a> smartly added him with very little fanfare on Friday, a move that could pay on-field dividends down the road.</p><p><b>Farrell’s take: </b>Legette is a terrific athlete who played quarterback and showed off his ability with the football in high school. He projects as a wide receiver at the next level and has good size and strength. He’ll be more of a possession guy for South Carolina until he adds a bit more speed but I see him as an excellent red zone threat and an important late pickup for the Gamecocks. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://southcarolina.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/y9nzirqrrxrjabiwnzj1)'></div>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/y9nzirqrrxrjabiwnzj1" alt="Y9nzirqrrxrjabiwnzj1" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='217361'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p><a href="https://miami.rivals.com">Miami </a>finished Wednesday with just 14 commits and ranked in the 40s of the <a href="http://rivals.com/">Rivals.com</a> Team Rankings, a position that Hurricanes fans aren’t used to seeing. While adding two-star ElGammal late didn’t really make an impact on that, it did at a player at a position of need. With so few big-name players still on the market, Miami will have to hope that ElGammal is one of several diamonds in the rough the school can unearth over the next month.</p><p><b>Farrell’s take: </b>ElGammal is very thin for his frame right now and has to be considered a bit of a project. However, athletic kids like ElGammal could turn into home run recruits, as they have just started to scratch the surface of their potential. He isn’t a big-name recruit for Miami and could be a reach, but time will tell. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://miami.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/l11ponn34wmu33xdfklh)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/l11ponn34wmu33xdfklh" alt="L11ponn34wmu33xdfklh" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='192367'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Moore was a pleasant surprise for <a href="https://washingtonstate.rivals.com">Washington State</a> fans when he sent in his letter-of-intent on Friday. A long defensive back who played at the JUCO level last season, Moore will be counted on to step in and have an impact early in Pullman. His late add is big, especially considering Washington State defensive back commit <a href="https://n.rivals.com/content/prospects/2019/don-chapman-215359">Don Chapman</a> elected not to sign early. </p><p><b>Farrell’s take: </b>Moore is very raw as a defensive back but has a lot of potential because of his size. He’s a big kid with length and size and should be ready to impact right away for Washington State. He could end up at safety or be a big corner and I think he’ll be an impact guy before too long. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://washingtonstate.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/kssjkauk7mg8h12xu7mk)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/kssjkauk7mg8h12xu7mk" alt="Kssjkauk7mg8h12xu7mk" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='234291'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>Howard is about as under the radar as it gets, as he netted a late offer and quickly jumped on a chance to sign with the Bears. Despite playing on a team loaded with prospects, it took all the way until the signing period for him to get a Power Five offer. <a href="https://baylor.rivals.com">Baylor </a>is hoping that they found a contributor in the heart of SEC country.</p><p><b>Farrell’s take: </b>Howard plays on a good high school football team and got noticed because of his heavily recruited teammates. Sometimes that can work out well for prospects as they exceed expectations. He has good size and athleticism and it will be interesting to see how he impacts at Baylor in the long run. </p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://baylor.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/b1btvjtw5a4auqsmhz4r)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/b1btvjtw5a4auqsmhz4r" alt="B1btvjtw5a4auqsmhz4r" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period/printable' site-name='Rivals.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"FancastLeaderboard","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":3,"footballYear":2019,"basketballYear":2019}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2018' site='{"id":173,"legacy_id":1014,"name":"Rivals.com","friendly_name":"Rivals","annual_discount":null,"subdomain":"rivals","primary_color":"0A4EA3","secondary_color":"464646","font_color":"ffffff","short_name":"Rivals","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81884779-1"}' twitter-feed='{"id":172,"site_id":173,"handle":"rivals","list_name":"Rivals-National","created_at":"2016-02-01T12:25:40.011-06:00","updated_at":"2017-09-05T11:55:48.870-05:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period/printable' site-name='Rivals.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719147', 'https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Early Signing Period: Late additions that flew under the radar ";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("Rivals", 1997416, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://n.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Oath Inc</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719147",
    c7: "https://n.rivals.com/news/late-additions-that-flew-under-the-radar-in-the-early-signing-period"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fn.rivals.com%2Fnews%2Flate-additions-that-flew-under-the-radar-in-the-early-signing-period&c5=2022719147&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
